PDA

View Full Version : code p0325



Giggle Squirt
03-21-2009, 09:10 AM
OK so last night my light from hell came on and i scanned it this morning and got a code for a knock sensor... No pending codes, and i cleared the code and it came back with in like half a km of driving... Now would this cause my car to hesitate? And it is not comming off high idle as fast at it normally does. At start up it usually hangs around 2000 for a second then kicks down to it's normal idle of arund 700... But it has hanging at 2000 for a bit longer then normal... ... needless to say a new knock sensor is 294 dealer... 172 after market :(



Also... I am getting a vibration at around 60km and 120 km... nothign inbetween.. I had tires checked balanced... suspension checked alignment checked and nothing was out... i am thinking u joints... the vibration is not in the steering , more in the seat and it feels like it is from the rear... would u joints cause this???

DM46
04-10-2009, 10:28 AM
if your feeling the vibration in your seat it's most definately a rear vibration. That could be caused by:
bent rims
broken belts on tires
bad wheel bearings
tires out of balance

Barry Morris
04-10-2009, 11:01 AM
Also U joints!!!

DM46
04-20-2009, 03:45 PM
dito, for got all about ujoints lol, but seeing as giggle is describing a car, its most likely fwd and the u joints in the front would have no connection to the vibration in the rear

Giggle Squirt
04-20-2009, 05:31 PM
actually my car is AWD so their are rear u joints... brand new tires, no broken belts, no bent rims, balanced tires 3 times and they came out balanced every time... it is the U joints... but it s buy a drive shaft get a free u joint deal.. :( I got the knock sensor changed, and now the iac motor is sticking.. YAY ME

Giggle Squirt
05-30-2009, 12:00 AM
So just thought i would update... Over a month of trying to figure out why my car was vibrating the hell out of itself turns out that my two rear tires were out of round. So 2 new tires later and it rides so dam smooth i kinda miss the vibration :(

Luv'inLife
05-30-2009, 12:39 AM
vibration in the seat means you left your toy in the car...go get it before the battery is dead.

_daynzy
05-30-2009, 06:36 AM
isnt it better to do all 4 tires when it's awd?

Giggle Squirt
05-30-2009, 09:30 AM
i just put 4 brand spanking new tires on it a few months ago... 2 of them were bad. SO i got them replaced. Their was no wear on the fronts. and all the dot numbers are close..

Barry Morris
05-30-2009, 12:26 PM
So just thought i would update... Over a month of trying to figure out why my car was vibrating the hell out of itself turns out that my two rear tires were out of round. So 2 new tires later and it rides so dam smooth i kinda miss the vibration :(

A tire balance would have caught that. I assume your tire guy is incompetent.

Giggle Squirt
05-30-2009, 01:09 PM
yep the tire guy is incompetent... which is why i got some one else to look at it.

icecapp
06-05-2009, 11:00 AM
OK so last night my light from hell came on and i scanned it this morning and got a code for a knock sensor... No pending codes, and i cleared the code and it came back with in like half a km of driving... Now would this cause my car to hesitate? And it is not comming off high idle as fast at it normally does. At start up it usually hangs around 2000 for a second then kicks down to it's normal idle of arund 700... But it has hanging at 2000 for a bit longer then normal... ... needless to say a new knock sensor is 294 dealer... 172 after market :(



Also... I am getting a vibration at around 60km and 120 km... nothign inbetween.. I had tires checked balanced... suspension checked alignment checked and nothing was out... i am thinking u joints... the vibration is not in the steering , more in the seat and it feels like it is from the rear... would u joints cause this???


Giggle Im not a mechanic but my husband is.. and it just so happens I have his eec-v code list infront of me.... to read his list for your code it says kinda what you are saying.. but his reads

A "Spark" Knock Occurred & Sensor Circuitry did not respond.. sounds more like spark plug issue not firing on proper time to respond back to all the rest of the computer crap ....

I would say nothing with u joints, or tires or steering.....

bowtie
07-01-2009, 08:31 AM
do you run american gas?

rmkryan
07-01-2009, 02:15 PM
Giggle Im not a mechanic but my husband is.. and it just so happens I have his eec-v code list infront of me.... to read his list for your code it says kinda what you are saying.. but his reads

A "Spark" Knock Occurred & Sensor Circuitry did not respond.. sounds more like spark plug issue not firing on proper time to respond back to all the rest of the computer crap ....

I would say nothing with u joints, or tires or steering.....



Thanks the tire issue was a seperae issue. my tires were out of round, got new tires and problem solved.

rmkryan
07-01-2009, 02:20 PM
do you run american gas?

We filled up with american gas in the old car and hand no issues, this car does not like american gas, we have stopped filling up in america unless we are travelling or something and need it fill up. It wasn't cheaper for us to fill up across the ditch becase we would have to throw a bottle of fuel additive in tank to get it to run half decent.

DM46
08-15-2009, 04:07 PM
We filled up with american gas in the old car and hand no issues, this car does not like american gas, we have stopped filling up in america unless we are travelling or something and need it fill up. It wasn't cheaper for us to fill up across the ditch becase we would have to throw a bottle of fuel additive in tank to get it to run half decent.

This is because American premium is our equivalent to regular. In the states it doesnt get as cold so the gasoline doesn't need to be as high grade as in Canada. Every vehicle I have owned ran better on Canadian Regular than on American Premium. (Sorry Slow this isn't another chance for you to belittle Canada).

DM46
08-15-2009, 04:09 PM
actually my car is AWD so their are rear u joints... brand new tires, no broken belts, no bent rims, balanced tires 3 times and they came out balanced every time... it is the U joints... but it s buy a drive shaft get a free u joint deal.. :( I got the knock sensor changed, and now the iac motor is sticking.. YAY ME

This I don't understand? Just exactly how much would you pay for the driveshaft. I'll guarantee a Subaru rear drive shaft is not cheap. U'joints on the other hand would probably go for about 20-25 bucks each, and I could change them in a matter of 15minutes.

Giggle Squirt
08-15-2009, 11:54 PM
823.19 for the rear drive shaft plus the ujoints. they are not cheap either. oh and not to mention shipping.