PDA

View Full Version : Help with ubuntu feisty xorg.conf



jessiec
07-31-2007, 01:09 PM
Greetings. Need help in editing xorg.conf from "terminal".
I am asked for password but I do not get"section files.....input,device,monitor etc etc." All I get is a blank file"xorg.conf".
Where do I need to be as a user to edit these files. Any help greatly appreciated. /ubbthreads/images/%%GRAEMLIN_URL%%/Coffee.gif

Hans
07-31-2007, 02:07 PM
Looks like your terminal is not in the proper user mode.
Open the terminal, type in SU and provide your password.
From there you should be able to open the xorg.conf file.

Note : You should be open to select "open terminal window here" from your file explorer, which saves you the hassle of manually going to the proper directory if you just open a prompt. You should see the file xorg.conf in your file explorer.

jessiec
07-31-2007, 02:30 PM
Tried....not authorized?????
All I get....XXXX@XXXX-laptop:~$
Have tried "sudo .......etc" but a blank folder results!!!!
Thanks for answering :-):-)...I'm very new to Linux. I enjoy the special features and effects.

DoubleXL
07-31-2007, 03:21 PM
Try from a terminal window

sudo nautilus

this should load the file manager with elevated permissions

or, if you just want to edit the file with elevated permissions then type

sudo gedit /etc/X11/xorg.conf

it is case sensitive. You can then save it. You will need to provide the password you use to get into ubuntu

jessiec
07-31-2007, 04:18 PM
hi..still get a blank file folder named "xorg.conf"
And thanks for the reply.

Hans
07-31-2007, 09:00 PM
xorg.conf should be a file, not a folder. I am a little confused as to the blank file folder named xorg.conf...

Open a prompt and type in one of the following :

gksu gedit /etc/X11/xorg.conf

kdesu kate /etc/X11/xorg.conf

gksu mousepad /etc/X11/xorg.conf

If all of the above fails (it should not), use :

sudo nano /etc/X11/xorg.conf

If you get a blank file on all of these then I can only conclude you have a bad xorg.conf
Which is kind of odd, as you obviously have a working gui...

jessiec
08-01-2007, 05:37 PM
Hi. When I type "sudo gedit xorg.conf" at the terminal,I'm asked for the password. Then I get "xorg.conf(/home/xxxx)-edit and the file tab says xorg.conf but the rest is blank. I'm trying to edit this...."Section "Device"
Identifier "S3 Inc. 86C270-294 Savage/IX-MV"
Driver "savage"
BusID "PCI:1:0:0"
VideoRam 8192
Option "ShadowStaus" "true"
Option "AGPMode" "2"
Option "DmaMode" "None"
This is to address the bug 33617 ....with my IBM T21 laptop,and Ubuntu Feisty Fawn OS.
All I see under.."Device" is.. Identifier....
Driver.....
BusID...... I would like to add the rest,as above, as per "bug fix"
A bit of a challenge but worth trying.....yes the T21 freezes with a blank screen as the write up states.
Sorry for the l o n g winded issue I have described. Have a great day and thanks for the reply. :-):-)

Hans
08-02-2007, 11:05 AM
xorg.conf is located under /etc/X11/ . It looks like you are trying to open "xorg.conf(/home/xxxx)-edit and the file tab says xorg.conf but the rest is blank.

/home/ is your home directory for the user account you use to log into Feisty.

If you open a prompt, navigate to /etc/X11/
Then try sudo gedit xorg.conf again.

jessiec
08-02-2007, 02:48 PM
That did it....Thanks ever so much....you're the man :-):-) Have a great day.

Hans
08-02-2007, 07:21 PM
NP, have fun with your Linux installation.

1337
08-04-2007, 12:47 AM
LOL, Terminal. I was a hardcore console junky. Hated X windows.

Ahh everything in text, that was beautiful.