Vianet.ca
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 21 to 26 of 26

Thread: Over heating engine issue???

  1. #21
    Moderator fenderbass's Avatar
    Join Date
    Jan 2006
    Location
    not here, but there
    Posts
    1,640

    Default Re: Over heating engine issue???

    temp sender unit is in the cyl head(left) just above the
    exaust manifold. at clys#1 and #3
    Die Lügen sind wie Schneebälle: je weiter man sie fortwälzt, desto größer werden sie: Lies are like snowballs: the farther they roll, the greater they grow

  2. #22
    Senior Member MaO3's Avatar
    Join Date
    Dec 2003
    Location
    Just North of Town
    Posts
    9,934

    Default Re: Over heating engine issue???

    Well an update for you all. He took his truck in to White Pines and worked with the auto teacher on it today.

    He's ordered a temp sender unit, that should fix the problem, they checked the fluid temp and it was staying at about 86 when the guage was reading 110.
    Attitude is contagious - is your's worth catching?
    The heaviest thing you can carry is a grudge..
    Make peace with your past, so it wont spoil the present

  3. #23
    J*B
    Guest

    Default Re: Over heating engine issue???

    I suspected that little bugger! lol

  4. #24
    Moderator
    Join Date
    Sep 2001
    Location
    Sault
    Posts
    37,746

    Default Re: Over heating engine issue???

    AHA!!!!
    Religion doesn't save you, change you. heal you or set you free. Jesus does.

    "if you could lose your salvation, you would!" John Macarthur

    I promise to always post sober.

  5. #25
    Senior Member MaO3's Avatar
    Join Date
    Dec 2003
    Location
    Just North of Town
    Posts
    9,934

    Default Re: Over heating engine issue???

    Thanks for all your help guys, it gave him starting point.
    Attitude is contagious - is your's worth catching?
    The heaviest thing you can carry is a grudge..
    Make peace with your past, so it wont spoil the present

  6. #26
    Senior Member
    Join Date
    Mar 2008
    Posts
    247

    Default Re: Over heating engine issue???

    one issue could be that the red antyfreeze was desinged for the newer cars for GM but ur rad cold also be pluged from inside were u dont see it if doing a flush dont change this try another thermostat some are known to be defective if not a new rad would be in order

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts