Vianet.ca
+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 21 to 26 of 26

Thread: best place to get transmission serviced?

  1. #21
    Senior Member General Lee's Avatar
    Join Date
    Feb 2005
    Location
    I
    Posts
    10,602

    Default Re: best place to get transmission serviced?

    i decided to buy the filter and gasket and do it my self

  2. #22
    Senior Member _daynzy's Avatar
    Join Date
    Dec 2006
    Location
    Sault Ste. Marie, ON
    Posts
    2,329

    Default Re: best place to get transmission serviced?

    they're pretty easy to do.. we did the one on my truck in our drive way.. make sure if it's a rubber gasket you don't glue it

  3. #23
    Senior Member hemi_69's Avatar
    Join Date
    May 2004
    Location
    sault ste marie
    Posts
    2,572

    Default Re: best place to get transmission serviced?

    agreed, and make sure to gently and evenly tighten the pan so you dont bend it

  4. #24
    Moderator
    Join Date
    Sep 2001
    Location
    Sault
    Posts
    37,746

    Default Re: best place to get transmission serviced?

    Don't glue??? Why not??
    Religion doesn't save you, change you. heal you or set you free. Jesus does.

    "if you could lose your salvation, you would!" John Macarthur

    I promise to always post sober.

  5. #25
    Senior Member _daynzy's Avatar
    Join Date
    Dec 2006
    Location
    Sault Ste. Marie, ON
    Posts
    2,329

    Default Re: best place to get transmission serviced?

    the glue makes the rubber gasket wavy, ripples.. which allows cracks and way for oil to seep out

  6. #26
    hp2
    Guest

    Default Re: best place to get transmission serviced?

    <div class="ubbcode-block"><div class="ubbcode-header">Originally Posted By: Barry Morris</div><div class="ubbcode-body">hp2, I was warned by my above reccommended shop NOT to get a tranny flush because it only loosens up junk in the thing that will cause it to quit in 6 months.

    Please keep us posted!!!! </div></div>


    Tranny is working a1 this last month.. after the flush.. we are talking about doing it again.. it was not a full flush fluid outa the tourque sp converter was not taken.. so mixed in with some of the old oil.. it worked great for a bit after.. then was doing it again.. Now has not done it in a really long long time.. actually I forgot about the problem till I just read this lol.. all filters were changed as well.

    all is good here...

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts